API Token Stopped Working On Virtual Account

My API token for my virtual account (VRTC2197649), which I have been using for several months abruptly stopped working today. There were no code changes to the app which has been working perfectly for several months but the app failed to login today with an authorization ‘CallError’ error “Sorry, an error occurred while processing your request”.

The issue is easily reproduced in the Binary API ‘playground’ (https://www.binary.com/en/user/security/api_tokenws.html). I type in the token given to me for my virtual application (at https://www.binary.com/en/user/security/api_tokenws.html) and the error I get is shown below (in JSON format)

{
"echo_req": {
"authorize": ""
},
"error": {
"code": "CallError",
"message": "Sorry, an error occurred while processing your request."
},
"msg_type": "authorize"
}

I attempted to delete the token at https://www.binary.com/en/user/security/api_tokenws.html but this did not work either with “sorry something went wrong” error. The idea was to generate a new API token and see if that worked, however the Binary websitee did not allow me to delete the currently not working API token and the website also did not allow me to create a new API Token. I have run out of options.

Please can anyone help?

Comments

  • The JSON call did have a parameter for authorize - I've just not shown it.

    {
    "echo_req": {
    "authorize": ""
    },
    "error": {
    "code": "CallError",
    "message": "Sorry, an error occurred while processing your request."
    },
    "msg_type": "authorize"
    }

  • OK after several hours the authorize has just started working again. I guess this must be unscheduled maintenance/glitch.

  • @JetBrainsDude there was an issue with the API.

Sign In or Register to comment.